docker相关的信息

Linux 下安装docker for centos8,以及docker-compose

6个月前 (2020-01-21) 1531 浏览 评论

Linux 下安装 Docker 系统,最低需要 CentOS 7(这里以 CentOS 8 为例,和 7 是有差别的)。| 安装依赖请先安装依赖,以免出现各种问题# 首先我们设置 Docker 仓库 sudo yum install -y yum-utils device-mapper-persistent-data lvm2 # 设置稳定的仓库 sudo&nbs

Mac下安装docker,并使用docker-compose安装PHP开发环境

11个月前 (2019-08-21) 1337 浏览 评论

安装 Docker for Mac 系统最低需要 macOS 10.10.3 Yosemite。| Homebrew安装查看是否安装Homebrew$ brew --version Homebrew 2.1.2若未安装,我们来安装下:/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/m

mmap(xxx) failed / ERROR calloc[1] failed 解决方案

1年前 (2019-04-09) 404 浏览 评论

     在docker中启用swoole时报的错误,可以确定是内存问题[2019-04-09 09:04:32 @220.0]    WARNING swShareMemory_mmap_create: mmap(260046944) failed. Error: Cannot allocate memory[12]

swoole如何在后台运行

1年前 (2019-03-28) 805 浏览 评论

    开启守护进程。设置daemonize => 1时,程序将转入后台作为守护进程运行。长时间运行的服务器端程序必须启用此项。<?php $server = new swoole_websocket_server("0.0.0.0", 9501); $server->set(     array(    &

docker php-rdkafka 扩展安装和使用

1年前 (2019-03-13) 1629 浏览 评论

官方文档镇楼:https://arnaud-lb.github.io/php-rdkafka/phpdoc/book.rdkafka.html安装rdkafka需要依赖librdkafka,所以先安装librdkafka| 安装librdkafkagit clone https://github.com/edenhill/librdkafka.git cd librdkafka/ ./configure make &&